summaryrefslogtreecommitdiff
path: root/dev-python/uri_template/uri_template-1.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/uri_template/uri_template-1.2.0.ebuild')
-rw-r--r--dev-python/uri_template/uri_template-1.2.0.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-python/uri_template/uri_template-1.2.0.ebuild b/dev-python/uri_template/uri_template-1.2.0.ebuild
index 2aa659f49c57..90ea54cc924f 100644
--- a/dev-python/uri_template/uri_template-1.2.0.ebuild
+++ b/dev-python/uri_template/uri_template-1.2.0.ebuild
@@ -4,19 +4,24 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
inherit distutils-r1
MY_P="${PN}-v${PV}"
DESCRIPTION="URI Template expansion in strict adherence to RFC 6570"
-HOMEPAGE="https://gitlab.linss.com/open-source/uri_template/"
-SRC_URI="https://gitlab.linss.com/open-source/${PN}/-/archive/v${PV}/${MY_P}.tar.gz"
+HOMEPAGE="
+ https://gitlab.linss.com/open-source/uri_template/
+ https://pypi.org/project/uri-template/
+"
+SRC_URI="
+ https://gitlab.linss.com/open-source/${PN}/-/archive/v${PV}/${MY_P}.tar.gz
+"
S="${WORKDIR}/${MY_P}"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
python_test() {
"${EPYTHON}" "test.py" || die "Tests fail with ${EPYTHON}."