summaryrefslogtreecommitdiff
path: root/dev-python/uri_template/uri_template-1.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/uri_template/uri_template-1.1.0.ebuild')
-rw-r--r--dev-python/uri_template/uri_template-1.1.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/uri_template/uri_template-1.1.0.ebuild b/dev-python/uri_template/uri_template-1.1.0.ebuild
new file mode 100644
index 000000000000..d8cf7ad1ea00
--- /dev/null
+++ b/dev-python/uri_template/uri_template-1.1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P="${PN}-v${PV}"
+DESCRIPTION="URI Template expansion in strict adherence to RFC 6570"
+HOMEPAGE="https://gitlab.linss.com/open-source/uri_template/"
+SRC_URI="https://gitlab.linss.com/open-source/${PN}/-/archive/v${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+python_test() {
+ "${EPYTHON}" "test.py" || die "Tests fail with ${EPYTHON}."
+}