summaryrefslogtreecommitdiff
path: root/dev-python/uncertainties/uncertainties-3.1.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/uncertainties/uncertainties-3.1.4.ebuild')
-rw-r--r--dev-python/uncertainties/uncertainties-3.1.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/uncertainties/uncertainties-3.1.4.ebuild b/dev-python/uncertainties/uncertainties-3.1.4.ebuild
new file mode 100644
index 000000000000..f1decac029b5
--- /dev/null
+++ b/dev-python/uncertainties/uncertainties-3.1.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for calculations with uncertainties"
+HOMEPAGE="https://pythonhosted.org/uncertainties/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests nose
+
+ppython_compile_all() {
+ if use doc; then
+ PYTHONPATH="${BUILD_DIR}"/lib esetup.py build_sphinx
+ fi
+}
+
+python_compile_all() {
+ use doc && "${PYTHON}" setup.py build_sphinx
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( build/sphinx/html/. )
+ distutils-r1_python_install_all
+}