summaryrefslogtreecommitdiff
path: root/dev-python/uncertainties/uncertainties-3.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/uncertainties/uncertainties-3.0.1.ebuild')
-rw-r--r--dev-python/uncertainties/uncertainties-3.0.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/uncertainties/uncertainties-3.0.1.ebuild b/dev-python/uncertainties/uncertainties-3.0.1.ebuild
new file mode 100644
index 000000000000..c50978aff237
--- /dev/null
+++ b/dev-python/uncertainties/uncertainties-3.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for calculations with uncertainties"
+HOMEPAGE="https://pythonhosted.org/uncertainties/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+ppython_compile_all() {
+ if use doc; then
+ PYTHONPATH="${BUILD_DIR}"/lib esetup.py build_sphinx
+ fi
+}
+
+python_compile_all() {
+ use doc && "${PYTHON}" setup.py build_sphinx
+}
+
+python_test() {
+ esetup.py nosetests -sv || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( build/sphinx/html/. )
+ distutils-r1_python_install_all
+}