summaryrefslogtreecommitdiff
path: root/dev-python/tzlocal/tzlocal-4.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tzlocal/tzlocal-4.3.ebuild')
-rw-r--r--dev-python/tzlocal/tzlocal-4.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/tzlocal/tzlocal-4.3.ebuild b/dev-python/tzlocal/tzlocal-4.3.ebuild
new file mode 100644
index 000000000000..710a1143a1b7
--- /dev/null
+++ b/dev-python/tzlocal/tzlocal-4.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="tzinfo object for the local timezone"
+HOMEPAGE="
+ https://github.com/regebro/tzlocal/
+ https://pypi.org/project/tzlocal/
+"
+SRC_URI="
+ https://github.com/regebro/tzlocal/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytz_deprecation_shim[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest