summaryrefslogtreecommitdiff
path: root/dev-python/tzdata/tzdata-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tzdata/tzdata-9999.ebuild')
-rw-r--r--dev-python/tzdata/tzdata-9999.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/tzdata/tzdata-9999.ebuild b/dev-python/tzdata/tzdata-9999.ebuild
deleted file mode 100644
index 97edbcdcb47d..000000000000
--- a/dev-python/tzdata/tzdata-9999.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="tzdata shim to satisfy requirements (while using system tzdata)"
-HOMEPAGE="https://peps.python.org/pep-0615/"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ppc64 ~riscv ~s390 ~sparc x86"
-
-RDEPEND="
- sys-libs/timezone-data
-"
-
-src_unpack() {
- mkdir "${S}" || die
- cat > "${S}/pyproject.toml" <<-EOF || die
- [build-system]
- requires = ["hatchling"]
- build-backend = "hatchling.build"
-
- [project]
- name = "tzdata"
- version = "9999"
- description = "tzdata shim to satisfy requirements (using system tzdata)"
-
- [tool.hatch.build.targets.wheel]
- # apparently it doesn't have to exist...
- packages = ["gentoo_tzdata"]
- EOF
-}