summaryrefslogtreecommitdiff
path: root/dev-python/typeguard/typeguard-2.13.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/typeguard/typeguard-2.13.3-r1.ebuild')
-rw-r--r--dev-python/typeguard/typeguard-2.13.3-r1.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/typeguard/typeguard-2.13.3-r1.ebuild b/dev-python/typeguard/typeguard-2.13.3-r1.ebuild
deleted file mode 100644
index d40683e5eb2b..000000000000
--- a/dev-python/typeguard/typeguard-2.13.3-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Run-time type checker for Python"
-HOMEPAGE="
- https://pypi.org/project/typeguard/
- https://github.com/agronholm/typeguard/
-"
-SRC_URI="
- https://github.com/agronholm/typeguard/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-PATCHES=(
- # backport from https://github.com/agronholm/typeguard/pull/243
- "${FILESDIR}"/${P}-test.patch
-)
-
-python_test() {
- local EPYTEST_IGNORE=(
- # mypy changes results from version to version
- tests/mypy
- )
-
- local -x PYTHONDONTWRITEBYTECODE=
- epytest
-}