summaryrefslogtreecommitdiff
path: root/dev-python/trimesh
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/trimesh')
-rw-r--r--dev-python/trimesh/Manifest2
-rw-r--r--dev-python/trimesh/trimesh-4.2.0.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index d10cde6c9a1a..1a2c92e484e9 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1,5 +1,7 @@
DIST trimesh-4.1.5.gh.tar.gz 13440026 BLAKE2B bdf27c0ebfc24ede66ecd8ae94151cbf926e187112f096246080db34a43a23f950674a461c29d8b87a71d6b5bc8e3cc824007b54be90593ceb552e1669e41e36 SHA512 a62cdbad4a053fe6bf3d70285c2484600af09f9bc6a638214b10718bdf3c0901053bad0d25c4d7dc96f396c66fb3d438981d3fc96ea179bb078abb3d8b87695b
DIST trimesh-4.1.8.gh.tar.gz 13440336 BLAKE2B aa4bddc3d613144a0e304ec320a2b38df213846260e2525dae0f0f35a4146561e7b81dc88e197a5b0f0a76ff4b757c30df2a68fe0db0d4a37cdc8a91aedc41ba SHA512 e20ca45f08a4d65c44c214b104af7c6d9d27121716ed7efd53a521c5b896ce788dba91b7794db518f26bb2ae86a1b8269af94f9b9381f8fdd342372b4ba86ce4
+DIST trimesh-4.2.0.gh.tar.gz 13553809 BLAKE2B 141aec46cb8bf2342251a72e5e4c1fbee1e33e4ff63d420cfa4db1758fc324d572d54932ce1526ba2df75d9770f001d9dbe41a79835837931c4c46221fbb6871 SHA512 75efd00ef5ff8f9c25bdfb06ab92fa09db154771356b18ebcf457cba4c2f366645084eb078e5e324cfb41fe101797694aa6b00005f7ccd1290ba4d2d6c088ebd
EBUILD trimesh-4.1.5.ebuild 1907 BLAKE2B b02ee3321503fde8e19c486893bf21339dc410c850b1c2cab8b7640fe749dbedfe31e186b7ea9e5cb55f2ba3a387ee3830d9fcd8348d2627edecf444f07ba711 SHA512 9b70b481442dfc837368866e2a5ac26aa7d67ccb296b723e233b6006d25cd7f12478e4b5990c5839a2aeed76b69a0dd423a871a96f36d005a70c734e74867c3a
EBUILD trimesh-4.1.8.ebuild 1952 BLAKE2B dfc4f8a737b468861e4a18b4d28a91a299b869bb2f236c1214230543b4f4f83ad773494a808eb63b2aca57bd82ec28a6ed7241c22bdca1b0ddf0ed5f8f4d0a4c SHA512 2c0531123d157cd0f3ddf4ee4da438ad06677d9549291ef0af0b08ff21819239ee152ee77651f8d770adca1f8dcf03b2070d63a6e844649ebe44c93b930abe13
+EBUILD trimesh-4.2.0.ebuild 1952 BLAKE2B dfc4f8a737b468861e4a18b4d28a91a299b869bb2f236c1214230543b4f4f83ad773494a808eb63b2aca57bd82ec28a6ed7241c22bdca1b0ddf0ed5f8f4d0a4c SHA512 2c0531123d157cd0f3ddf4ee4da438ad06677d9549291ef0af0b08ff21819239ee152ee77651f8d770adca1f8dcf03b2070d63a6e844649ebe44c93b930abe13
MISC metadata.xml 495 BLAKE2B b8b403f7bfbac53ed234c2ba50324041502a28465d70e9406867f05741e0313845307491fcfd85f05e2993b21daf14117a4b6863b45422fd4c62c6e28902e3ff SHA512 3deec8ab4b513536a7fe182be8f1b96e06fd06b2480d3e516c2b3462cc26fcbdeb1d165b4d0297465e93c0cce584ab40a8f905b81a59dcb4040a39655028783d
diff --git a/dev-python/trimesh/trimesh-4.2.0.ebuild b/dev-python/trimesh/trimesh-4.2.0.ebuild
new file mode 100644
index 000000000000..fdbbaa5a2b10
--- /dev/null
+++ b/dev-python/trimesh/trimesh-4.2.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimesh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ sci-libs/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mapbox_earcut[${PYTHON_USEDEP}]
+ dev-python/pillow[webp,${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_TIMEOUT=1800
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox_earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" dev-python/scikit-image
+}