summaryrefslogtreecommitdiff
path: root/dev-python/translationstring
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/translationstring')
-rw-r--r--dev-python/translationstring/Manifest3
-rw-r--r--dev-python/translationstring/metadata.xml12
-rw-r--r--dev-python/translationstring/translationstring-1.3.ebuild40
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/translationstring/Manifest b/dev-python/translationstring/Manifest
new file mode 100644
index 000000000000..920f24c074f9
--- /dev/null
+++ b/dev-python/translationstring/Manifest
@@ -0,0 +1,3 @@
+DIST translationstring-1.3.tar.gz 29259 BLAKE2B 650c4e294796e1409246cf2f4effdd58bffecc2912e57ea4268d77d38997d2997b329936749af10c8c7625729a6503288cb8aa54baf1a3c07b3671cda0561833 SHA512 deba5b460d9ea640087cff8b5d7b9256708abd4340a54556f1f0542e2e4f9f0ae0a3482b66a176712fcd6925c470da621adbc5e4c4173c0ef29b9cca5fba1102
+EBUILD translationstring-1.3.ebuild 1107 BLAKE2B 2b0993c2d87a4ac0e062af1c7355fc7cc60303cb4233ef0e12ba7cc791968742786e999670e382e53232605f31abfc736e858b02b91f02dc2468711c4fb7beb6 SHA512 1808cf827b14e9ada34de65ae50420f9ee8c2c46f54ccee8b31f4b589e982fba331568f8db6dc72a75e0f1e298e22c4ed228b56e94f56a9ac04b0e5f0c4de2bf
+MISC metadata.xml 396 BLAKE2B dd74b39a6a434cd88f9cdc36dfa838457d0a7e6677f68e4b687844c1861b25407cbe756af94995ceab82b55b0a607118060579c1c3bf40d78d8299f1a62a4066 SHA512 6cfbb09e766bb9c10523808ea4da01f0998e03c239f633347523f57177816bb4c6efca2567ba53b2bf5b41274a3845d8a379294172c94067bb02f901175cc9e8
diff --git a/dev-python/translationstring/metadata.xml b/dev-python/translationstring/metadata.xml
new file mode 100644
index 000000000000..29d999ecc33d
--- /dev/null
+++ b/dev-python/translationstring/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">translationstring</remote-id>
+ <remote-id type="github">Pylons/translationstring</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/translationstring/translationstring-1.3.ebuild b/dev-python/translationstring/translationstring-1.3.ebuild
new file mode 100644
index 000000000000..00cecce5d262
--- /dev/null
+++ b/dev-python/translationstring/translationstring-1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Utility library for i18n relied on by various Repoze packages"
+HOMEPAGE="https://github.com/Pylons/translationstring https://pypi.org/project/translationstring/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+# Include COPYRIGHT.txt because the license seems to require it.
+DOCS=( COPYRIGHT.txt README.rst )
+
+python_test() {
+ esetup.py test
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ # Install only the .rst source, as sphinx processing requires a
+ # theme only available from git that contains hardcoded references
+ # to files on https://static.pylonsproject.org/ (so the docs would
+ # not actually work offline). Install into a "docs" subdirectory
+ # so the reference in the README remains correct.
+ docinto docs
+ docompress -x usr/share/doc/${PF}/docs
+ dodoc docs/*.rst
+}