summaryrefslogtreecommitdiff
path: root/dev-python/translate-toolkit
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/translate-toolkit')
-rw-r--r--dev-python/translate-toolkit/Manifest2
-rw-r--r--dev-python/translate-toolkit/translate-toolkit-3.9.2.ebuild119
2 files changed, 0 insertions, 121 deletions
diff --git a/dev-python/translate-toolkit/Manifest b/dev-python/translate-toolkit/Manifest
index c754fcf1bd39..71b3acf86f0c 100644
--- a/dev-python/translate-toolkit/Manifest
+++ b/dev-python/translate-toolkit/Manifest
@@ -1,5 +1,3 @@
DIST translate-3.10.0.gh.tar.gz 1195239 BLAKE2B be1e2925632d032081a07cd99d540a90f4526810d5a9f587b4c651c41f7afe53ec212b408dfb81bf57a74fb286124c49b5b7f9f56a9c4b861c8874c7c6986532 SHA512 9669e4eccb68eab93ed7a35e2673df4f60bcc9602c4d97954180a8eb7e92ad9b82d2c8ef0caa8d8ce19ee2ae58e04867729bfd326c9e1a11a451d702372377fe
-DIST translate-3.9.2.gh.tar.gz 1175987 BLAKE2B 1d187f56f2cb003690038489bf2f788c8f60e9aef522642439f1ee169c7722f8b5646114e3fef2e6ba8f4b3a02ae27a58241c25a146dc6b0b7c8fbbe4044d1b5 SHA512 23c8238ee65ede57654e86e255608211b5f183b18bf7c2865fc5621a77619f1ad798b6e3be907adfa0db883b750db2d3be89001335d25afe6b259d8e91ba509c
EBUILD translate-toolkit-3.10.0.ebuild 3152 BLAKE2B f31981c7c11b1a55aca2a2fb6ec3d99515027614ea24f6733a81057d6addf8cf70daf8155f4dd4ba70350da496151c9d35c62b4a7b319b5770c04782e2b312a8 SHA512 53a16f4e03bf86db78f0d8dc1a7781f168e164b5fc57dca83b289d43689b47a5bd7aff0806b4d1a9e2d21862f9080deaf98d8ca7af7dfa9cb5de58a9204e754e
-EBUILD translate-toolkit-3.9.2.ebuild 3154 BLAKE2B 43567475e6458137fdf4dc75e73003d2acd11e833e79ab8905b44dd5aaf58f56eb6217f58cf6539ba6d79ed8f18b338f681a38c8112e43fa39917bc78ff21543 SHA512 e39823524dd8b6a0b810cc28810ec5789f979d22037be114478ff8352832eb117ccb80fd11691deedaefee0f2c03b36923590d144aea795a9e39619eb628e81d
MISC metadata.xml 756 BLAKE2B 06f64f258d362954f99f7e9eee241eb3dddc6b00b9069df2ad977d28b5cf06f9c8ee2246ee5958600b5ac86297968d7aaced6b6420dca4ed507c441c58c61ca9 SHA512 80374c40513ca450f97e3930929c1450e7438ea15830e60937952a6fccfd999675f2ca2056c5aa4e287ba256c6ec08a09d8f7adb8b2c5af8ca0cd595f34acd85
diff --git a/dev-python/translate-toolkit/translate-toolkit-3.9.2.ebuild b/dev-python/translate-toolkit/translate-toolkit-3.9.2.ebuild
deleted file mode 100644
index 838de39a5510..000000000000
--- a/dev-python/translate-toolkit/translate-toolkit-3.9.2.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-MY_P=translate-${PV}
-DESCRIPTION="Toolkit to convert between many translation formats"
-HOMEPAGE="
- https://github.com/translate/translate/
- https://pypi.org/project/translate-toolkit/
-"
-SRC_URI="
- https://github.com/translate/translate/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S="${WORKDIR}"/${MY_P}
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86"
-IUSE="+html +ical +ini +subtitles +yaml"
-
-RDEPEND="
- app-text/iso-codes
- >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
- dev-python/cheroot[${PYTHON_USEDEP}]
- >=dev-python/Levenshtein-0.12.0[${PYTHON_USEDEP}]
- >=dev-python/lxml-4.3.1[${PYTHON_USEDEP}]
- >=dev-python/pycountry-19.8.18[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-3[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- sys-devel/gettext
- html? ( dev-python/utidylib[${PYTHON_USEDEP}] )
- ical? ( dev-python/vobject[${PYTHON_USEDEP}] )
- ini? ( >=dev-python/iniparse-0.5[${PYTHON_USEDEP}] )
- subtitles? ( media-video/gaupol[${PYTHON_USEDEP}] )
- yaml? ( dev-python/pyyaml[${PYTHON_USEDEP}] )
-"
-# Technically, the test suite also has undeclared dependency
-# on dev-python/snapshottest but all the tests using it are broken
-# anyway, so we skip them.
-BDEPEND="
- test? (
- dev-python/phply[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_test() {
- # unfortunately, this bad quality package doesn't support XDG_DATA_DIRS
- # correctly, so we need to reassemble all data files in a single directory
- local -x XDG_DATA_HOME=${T}/share
- cp -r translate/share "${T}/" || die
- cp -r "${ESYSROOT}/usr/share"/gaupol "${XDG_DATA_HOME}"/ || die
-
- distutils-r1_src_test
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Fails with network-sandbox (and even with it off but w/ softer fail)
- 'tests/xliff_conformance/test_xliff_conformance.py::test_open_office_to_xliff'
- 'tests/xliff_conformance/test_xliff_conformance.py::test_po_to_xliff'
- # all tests based on snapshottest are broken and I'm too tired
- # to figure this out
- translate/tools/test_pocount.py::test_cases
- translate/tools/test_pocount.py::test_output
- translate/tools/test_junitmsgfmt.py::test_output
- )
- local EPYTEST_IGNORE=(
- # unpackaged fluent.*
- translate/storage/test_fluent.py
- # changes directory and does not change it back, sigh
- tests/odf_xliff/test_odf_xliff.py
- )
-
- if ! use ini; then
- EPYTEST_IGNORE+=(
- translate/convert/test_ini2po.py
- translate/convert/test_po2ini.py
- )
- fi
-
- if ! use subtitles; then
- EPYTEST_IGNORE+=(
- translate/storage/test_subtitles.py
- )
- fi
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- insinto /usr
- doins -r translate/share
-
- if ! use html; then
- rm "${ED}"/usr/bin/{html2po,po2html} || die
- fi
- if ! use ical; then
- rm "${ED}"/usr/bin/{ical2po,po2ical} || die
- fi
- if ! use ini; then
- rm "${ED}"/usr/bin/{ini2po,po2ini} || die
- fi
- if ! use subtitles; then
- rm "${ED}"/usr/bin/{sub2po,po2sub} || die
- fi
-}