summaryrefslogtreecommitdiff
path: root/dev-python/traitlets/traitlets-5.14.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/traitlets/traitlets-5.14.1.ebuild')
-rw-r--r--dev-python/traitlets/traitlets-5.14.1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/traitlets/traitlets-5.14.1.ebuild b/dev-python/traitlets/traitlets-5.14.1.ebuild
deleted file mode 100644
index 1eabacf54469..000000000000
--- a/dev-python/traitlets/traitlets-5.14.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A configuration system for Python applications"
-HOMEPAGE="
- https://github.com/ipython/traitlets/
- https://pypi.org/project/traitlets/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
-
-BDEPEND="
- test? (
- >=dev-python/argcomplete-2.0[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs/source \
- dev-python/myst-parser \
- dev-python/pydata-sphinx-theme
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_IGNORE=(
- tests/test_typing.py
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p pytest_mock
-}