summaryrefslogtreecommitdiff
path: root/dev-python/traitlets/traitlets-4.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/traitlets/traitlets-4.1.0.ebuild')
-rw-r--r--dev-python/traitlets/traitlets-4.1.0.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/traitlets/traitlets-4.1.0.ebuild b/dev-python/traitlets/traitlets-4.1.0.ebuild
deleted file mode 100644
index 729d7cbd0002..000000000000
--- a/dev-python/traitlets/traitlets-4.1.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit distutils-r1
-
-DESCRIPTION="A configuration system for Python applications"
-HOMEPAGE="https://github.com/ipython/traitlets"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="doc test"
-
-RDEPEND="
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/ipython_genutils[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- "
-DEPEND="
- doc? (
- dev-python/ipython_genutils[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- "
-
-python_prepare_all() {
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- nosetests --verbosity=3 traitlets || die
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}