summaryrefslogtreecommitdiff
path: root/dev-python/tox
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tox')
-rw-r--r--dev-python/tox/Manifest2
-rw-r--r--dev-python/tox/tox-4.4.6.ebuild95
2 files changed, 97 insertions, 0 deletions
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index 813047e91cbb..0bd7c06cd65c 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -1,7 +1,9 @@
DIST tox-3.28.0.gh.tar.gz 309472 BLAKE2B 9896411426f6aebb3efa468c01696ecc5f17ec3e67825672d0efc74c1b1468bc8b8d9c14b6177c181750ba4b9a5e77d616068dd83e21f5641acfc8e2a271cc1f SHA512 64816754e6800661bb564c5c7d21c4139522d540a04fafe3c4591d596072d48d1cbe0ee2abee9c8faf3d5007774f5371431b5a7a8f49912bc879c7b168aab2ca
DIST tox-4.4.4.gh.tar.gz 303823 BLAKE2B 3386f00343035dd1d3fe58cb15cd666a55e7d77b84d93c87b5e3add24753255657591d0019a7a2349c081796e1bf096fc29b6451f0d5286e3b5b3ef18e5539c5 SHA512 d37fe82c685db238ab36929d5bfd1dece73ec36b533e027700c35cfe7c3bdff21639212dcb504c499739a17bc9cd600effe4e911a3572375912c4912bf4c5f45
DIST tox-4.4.5.gh.tar.gz 303977 BLAKE2B 4861add250b2fbd5736aed9183544f048194042ffbf059e38c551f96be2e0de043ec2877fac6dd51355d1553830f8b0d18c2d1f599c3cf9716882d78883f1c70 SHA512 38637caa136a54172d122aa2725787affdfef755f1dae4fcee9dfb390191ef5932c3955fdd8283710a052e5632f393c39f3c69a12f95468dfb8870590a285c59
+DIST tox-4.4.6.gh.tar.gz 304337 BLAKE2B 2c157fe5febf1eb131d767ade87484880201bb37fa65a579abb9780d755d570f216b8f865dd2dd8dbb3a3af01be78133f9ac0b73a3166dfc2b9cd99f6547498a SHA512 403bca89228d665182bfbb61550dfd9e9fb4ce4a5592472d50cd38e3f264c806fa15bbdccc020a720ad69885d9be54a1f074f6d87549cbe2b523e53d870358dc
EBUILD tox-3.28.0.ebuild 1916 BLAKE2B bc1acd79c969c87cc3a6ca2058d2acd56e89672c033cb670a58906a41e321e94813a25a844bbcdc09781795611384ece6c80b1ce8a8dcc980b775213f27ee165 SHA512 0a756d8535e8eb1daf6b82ed541d18d7e5dbf608a9739580e708506ffb9ad1b138211a1efe700bd4ecc7939c0150750fb0f0cc13f2db0d145fd8d943b7ecc1ce
EBUILD tox-4.4.4.ebuild 3036 BLAKE2B 406a88d17792ea4706036706c9c11ff6795394a6487a41a419cdd3bd3fcc95c3a5bf764892033d9e2512a53d972cd7ba8746555d21c44e0cd93cb4be206dec77 SHA512 91327d1b9a85cdad80d9c1ff1bb96bbd48f9d381d118815083af6c556bf53980fa0b475185c92fe1f13283fdea6a503a28d48d80d93bfd9e1f0815776fb96a58
EBUILD tox-4.4.5.ebuild 3037 BLAKE2B f016a50b7fe6b6c10e7d5f598000f796b815564a2519c72e7e98e4082fd576f3dbfc3443ed3a0c52907cf353d58b5fcd0f2be0be6f61780b7e36c2a06d445923 SHA512 5eb8f52d6ef0eec005e315df10389e6b5bb43716f1e592ec177b0410040fc4f0988bb13c65470d84455d36730b92eb115f1a2e5088562a79cf7ad8459742bc35
+EBUILD tox-4.4.6.ebuild 3037 BLAKE2B f016a50b7fe6b6c10e7d5f598000f796b815564a2519c72e7e98e4082fd576f3dbfc3443ed3a0c52907cf353d58b5fcd0f2be0be6f61780b7e36c2a06d445923 SHA512 5eb8f52d6ef0eec005e315df10389e6b5bb43716f1e592ec177b0410040fc4f0988bb13c65470d84455d36730b92eb115f1a2e5088562a79cf7ad8459742bc35
MISC metadata.xml 382 BLAKE2B 7c0704c5c187ce4a7972fe0372b23c5537a81a8d62fd83436d9558a61761f10764adb5a4d5f6795f0dd1fe905afa604c0be77fe1d48d291847f6ae65dc1b032c SHA512 9d0ced4df9352a81034a50d5766a01534ae8fa889985d99cc9e2a8d0889e31c6c11550677d9a5a74e2aab57c320192ce3a42708a6d23b0419ee34a6054398344
diff --git a/dev-python/tox/tox-4.4.6.ebuild b/dev-python/tox/tox-4.4.6.ebuild
new file mode 100644
index 000000000000..ff36971ecf17
--- /dev/null
+++ b/dev-python/tox/tox-4.4.6.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/_}
+DESCRIPTION="virtualenv-based automation of test activities"
+HOMEPAGE="
+ https://tox.readthedocs.io/
+ https://github.com/tox-dev/tox/
+ https://pypi.org/project/tox/
+"
+SRC_URI="
+ https://github.com/tox-dev/tox/archive/${PV/_}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/cachetools-5.3[${PYTHON_USEDEP}]
+ >=dev-python/chardet-5.1[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.4.6[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.9[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.6[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-1[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-api-1.5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+ >=dev-python/virtualenv-20.17.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/hatch-vcs-0.3[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/build-0.10[${PYTHON_USEDEP}]
+ >=dev-python/distlib-0.3.6[${PYTHON_USEDEP}]
+ >=dev-python/flaky-3.7[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.9.4[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.1[${PYTHON_USEDEP}]
+ >=dev-python/re-assert-1.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/time-machine-2.9[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+src_prepare() {
+ # the minimal bounds in tox are entirely meaningless and new packaging
+ # breaks setuptools
+ sed -i -e '/packaging/s:>=[0-9]\+::' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # devpi_process is not packaged, and has lots of dependencies
+ cat > "${T}"/devpi_process.py <<-EOF || die
+ def IndexServer(*args, **kwargs): raise NotImplementedError()
+ EOF
+
+ local -x PYTHONPATH=${T}:${PYTHONPATH}
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/tox_env/python/virtual_env/package/test_package_cmd_builder.py::test_build_wheel_external
+ )
+ local EPYTEST_IGNORE=(
+ # requires devpi*
+ tests/test_provision.py
+ )
+
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[explicit-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[constraints-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[explicit+requirements-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements_indirect-True-True]'
+ 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements_constraints_indirect-True-True]'
+ )
+
+ epytest
+}