summaryrefslogtreecommitdiff
path: root/dev-python/toro
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/toro')
-rw-r--r--dev-python/toro/Manifest4
-rw-r--r--dev-python/toro/files/toro-1.0.1-no-test-install.patch11
-rw-r--r--dev-python/toro/metadata.xml15
-rw-r--r--dev-python/toro/toro-1.0.1.ebuild38
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/toro/Manifest b/dev-python/toro/Manifest
new file mode 100644
index 000000000000..055da17726b8
--- /dev/null
+++ b/dev-python/toro/Manifest
@@ -0,0 +1,4 @@
+AUX toro-1.0.1-no-test-install.patch 278 BLAKE2B 87ac93c1b5a70eee2995e1466b771a8d6667c209deac9c872888b970792b3de0eda32a4f62b25eeb714c6600906779e949bb3b07a52c7faa240e4846ca12751b SHA512 e1a7eb6ba8898a112603ac1bdb3eea692c3bc52931a617bc12343e7c60980a4bedab93584347777cd4869085872ca7b7f7c0c8a083d175e0e2597214680a5f00
+DIST toro-1.0.1.tar.gz 57343 BLAKE2B 2269aa9d99eda60013c695c9acbf4f808562c0d7f4a79ee7d7402255af2ff600ad292949ac789b7a7c9429009cec41587052440e64f99edb7f88646dabd3b814 SHA512 a8a498868ff32dbd8ba9a0adf62b1fa2e9dea4f34be4e2701c08c7b58ef28b8daf4eab93916855a711a557049e587e886d6ba362487c151c5db34f6135f4f3e5
+EBUILD toro-1.0.1.ebuild 818 BLAKE2B 02c243db97602fd5da43b156b1d247cfa2e3688ea9ab383ad2fe94cc29fc7d5a8286dc8ceeb673e254cc029d5fc1a82552d8af1bd323d806dc48a016e212708f SHA512 dc71ad246e2fbc092aff1c1f22ee28c76d3cae2abc08fe2f01e714ca9cfe01aca96185f4ec3dde7d1d52ed5d5f3ef23f5bc2c086a38afb5637f8a06cd5edee01
+MISC metadata.xml 524 BLAKE2B 45ccb3fe7a751bcda58eb5948921c4c6e75080488ae7e40e1c924911c9ef2121dd9182dc638a411bb5892e80738afbe33cb909eb8b44f80ba4e4e4edc76796e8 SHA512 f95ad860f9ec86f41e8909c242e83262fc0ae48082d96891c7d00e937c8b87a1cf9585fc6c0fabe61ff5e94369c027c77a89de86415872dba47a0cb69fcb7164
diff --git a/dev-python/toro/files/toro-1.0.1-no-test-install.patch b/dev-python/toro/files/toro-1.0.1-no-test-install.patch
new file mode 100644
index 000000000000..637f9091ac42
--- /dev/null
+++ b/dev-python/toro/files/toro-1.0.1-no-test-install.patch
@@ -0,0 +1,11 @@
+--- a/setup.py.orig 2017-06-27 18:38:37.256325950 +0000
++++ b/setup.py 2017-06-27 18:38:48.896243950 +0000
+@@ -45,8 +45,6 @@
+ kwargs['use_2to3'] = True
+
+ packages = ['toro']
+-if "test" in sys.argv:
+- packages.append('test')
+
+ setup(name='toro',
+ version='1.0.1',
diff --git a/dev-python/toro/metadata.xml b/dev-python/toro/metadata.xml
new file mode 100644
index 000000000000..214465d52996
--- /dev/null
+++ b/dev-python/toro/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ A set of locking and synchronizing primitives analogous to those in Python’s
+ threading module or Gevent’s coros, for use with Tornado’s gen.engine.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">toro</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/toro/toro-1.0.1.ebuild b/dev-python/toro/toro-1.0.1.ebuild
new file mode 100644
index 000000000000..195bd0f7796e
--- /dev/null
+++ b/dev-python/toro/toro-1.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Synchronization primitives for Tornado coroutines"
+HOMEPAGE="https://github.com/ajdavis/toro/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="examples test"
+
+RDEPEND="
+ virtual/python-futures[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+PATCHES=(
+ "${FILESDIR}"/${P}-no-test-install.patch
+)
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}