summaryrefslogtreecommitdiff
path: root/dev-python/toro
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/toro')
-rw-r--r--dev-python/toro/Manifest4
-rw-r--r--dev-python/toro/files/toro-1.0.1-no-test-install.patch11
-rw-r--r--dev-python/toro/metadata.xml12
-rw-r--r--dev-python/toro/toro-1.0.1.ebuild38
4 files changed, 0 insertions, 65 deletions
diff --git a/dev-python/toro/Manifest b/dev-python/toro/Manifest
deleted file mode 100644
index 3f0d17b11103..000000000000
--- a/dev-python/toro/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX toro-1.0.1-no-test-install.patch 278 BLAKE2B 87ac93c1b5a70eee2995e1466b771a8d6667c209deac9c872888b970792b3de0eda32a4f62b25eeb714c6600906779e949bb3b07a52c7faa240e4846ca12751b SHA512 e1a7eb6ba8898a112603ac1bdb3eea692c3bc52931a617bc12343e7c60980a4bedab93584347777cd4869085872ca7b7f7c0c8a083d175e0e2597214680a5f00
-DIST toro-1.0.1.tar.gz 57343 BLAKE2B 2269aa9d99eda60013c695c9acbf4f808562c0d7f4a79ee7d7402255af2ff600ad292949ac789b7a7c9429009cec41587052440e64f99edb7f88646dabd3b814 SHA512 a8a498868ff32dbd8ba9a0adf62b1fa2e9dea4f34be4e2701c08c7b58ef28b8daf4eab93916855a711a557049e587e886d6ba362487c151c5db34f6135f4f3e5
-EBUILD toro-1.0.1.ebuild 784 BLAKE2B a3b7841fe0e138d7e789e12886dc99bf385e8c753dde081bab3f26ff47f26c790a32610a41a8e989d705b4a94a06abe2d16024057eca15f11d1d8348f37f7ed3 SHA512 e00ecbbd8028e9448ae5cde782b0eb2a412934250a475cb1f18ad1852a487472211dd0017328c2a719c501e2da677be29369c65ce7de888db28e7639d21dc8be
-MISC metadata.xml 444 BLAKE2B 0a6a5245f27b859a5158eb79a8729d22a5d5382ffecc50aeac2c6e290148fcc72d2ccc671469fe00457be64387598ec7c9b9cd0c4987c215ee5ee685ffa7e37d SHA512 62210a631809295df39c6a6392dc0074d342805fd36afc6014a7cb108a01f59158ee864f0919350cfd4aeb2f0f01ffa45901fd154633ce059ce8aa36be73e6de
diff --git a/dev-python/toro/files/toro-1.0.1-no-test-install.patch b/dev-python/toro/files/toro-1.0.1-no-test-install.patch
deleted file mode 100644
index 637f9091ac42..000000000000
--- a/dev-python/toro/files/toro-1.0.1-no-test-install.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/setup.py.orig 2017-06-27 18:38:37.256325950 +0000
-+++ b/setup.py 2017-06-27 18:38:48.896243950 +0000
-@@ -45,8 +45,6 @@
- kwargs['use_2to3'] = True
-
- packages = ['toro']
--if "test" in sys.argv:
-- packages.append('test')
-
- setup(name='toro',
- version='1.0.1',
diff --git a/dev-python/toro/metadata.xml b/dev-python/toro/metadata.xml
deleted file mode 100644
index f9ea20bf41e1..000000000000
--- a/dev-python/toro/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!--maintainer-needed-->
- <longdescription>
- A set of locking and synchronizing primitives analogous to those in Python’s
- threading module or Gevent’s coros, for use with Tornado’s gen.engine.
- </longdescription>
- <upstream>
- <remote-id type="pypi">toro</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/toro/toro-1.0.1.ebuild b/dev-python/toro/toro-1.0.1.ebuild
deleted file mode 100644
index 63cca62f741e..000000000000
--- a/dev-python/toro/toro-1.0.1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Synchronization primitives for Tornado coroutines"
-HOMEPAGE="https://github.com/ajdavis/toro/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- www-servers/tornado[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-PATCHES=(
- "${FILESDIR}"/${P}-no-test-install.patch
-)
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}