summaryrefslogtreecommitdiff
path: root/dev-python/tinydb/tinydb-3.1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tinydb/tinydb-3.1.3.ebuild')
-rw-r--r--dev-python/tinydb/tinydb-3.1.3.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/tinydb/tinydb-3.1.3.ebuild b/dev-python/tinydb/tinydb-3.1.3.ebuild
deleted file mode 100644
index 969de752f80d..000000000000
--- a/dev-python/tinydb/tinydb-3.1.3.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
-
-inherit distutils-r1
-
-DESCRIPTION="Tiny document-oriented database"
-HOMEPAGE="https://github.com/msiemens/tinydb
- https://pypi.org/project/tinydb/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- sed \
- -e "s:find_packages():find_packages(exclude=['tests']):g" \
- -i setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test -v -v || die
-}