summaryrefslogtreecommitdiff
path: root/dev-python/tinycss/tinycss-0.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tinycss/tinycss-0.4-r1.ebuild')
-rw-r--r--dev-python/tinycss/tinycss-0.4-r1.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/tinycss/tinycss-0.4-r1.ebuild b/dev-python/tinycss/tinycss-0.4-r1.ebuild
deleted file mode 100644
index c6b2dae8d2f2..000000000000
--- a/dev-python/tinycss/tinycss-0.4-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A complete yet simple CSS parser for Python"
-HOMEPAGE="
- https://github.com/Kozea/tinycss/
- https://pypi.org/project/tinycss/
- https://tinycss.readthedocs.io/en/latest/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- dev-python/lxml[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
-"
-
-DOCS=( CHANGES README.rst )
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs
-
-python_prepare_all() {
- rm setup.cfg || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- rm -rf tinycss || die
- epytest --pyargs tinycss
-}