summaryrefslogtreecommitdiff
path: root/dev-python/tifffile
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tifffile')
-rw-r--r--dev-python/tifffile/Manifest6
-rw-r--r--dev-python/tifffile/tifffile-2024.8.28.ebuild (renamed from dev-python/tifffile/tifffile-2024.6.18.ebuild)2
-rw-r--r--dev-python/tifffile/tifffile-2024.8.30.ebuild47
3 files changed, 52 insertions, 3 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index 4cc23936c341..8ad15a3071ab 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -1,3 +1,5 @@
-DIST tifffile-2024.6.18.gh.tar.gz 349752 BLAKE2B 35f11d963e93e6b1f6b5e4a026dd0f1aed1bf03a2a5e9caab7649ce95c00cdd99988aaa864c549555a8244ec8bfc8d8d900386aa7b9f853fd5aca7b8bece8eb4 SHA512 fdbb5b2b335743f0aef01d5a8f0b577eb24fb1b89d29e20c1971124bdb58f61aab4e3471b6f91e686010c8ca1d5786527357b123c2d801c16d423927315b8c94
-EBUILD tifffile-2024.6.18.ebuild 912 BLAKE2B 72f813492d481934acb63f72ede3145181f2e9267485b8fae567929a1e94e1a288599076851f8c67083687d282e8d16bbd90786c970d5b26e5c2e2843436229f SHA512 877932d4597684f7cfa0e2524b1192f14207febdfeb3a545253bb98c5c9d44c453161ea7d837c565ac5530d434fccbe842b70ddf4454ca60a9b2ad190523a7c6
+DIST tifffile-2024.8.28.gh.tar.gz 351568 BLAKE2B 4ee3c41f5ebb31b35e230c9784c89a43735d27b67e16d48a58ff2ee5ff0a28f3f84c2e02fd25ea1879b4adda0d70aae723a6ec93cb8f8b54e47680fb773c4d11 SHA512 5710de50e303f4012cd6bfdbbc4f6d4045b2917236dd268124df7326f36ef43b004bb4bed1b2d3b9444b55b2947b48a3882b6db2cb75582a990100e58c7d1105
+DIST tifffile-2024.8.30.gh.tar.gz 353606 BLAKE2B 866248a948e141d7feb0770d51ec0cef5ba8e6474eb1238cde877b0e04525ac9126e4e0b11f1f64811c6a81a7084f6382a0f35f5e35e54862331f979ce5faf70 SHA512 f81e93c55cc982e12c9f0872b8099cb5e1dc6f4a3d18411a1d0f073080e20bf35a89d7115f4c8617f83c923e04c371a0db64d10b121a254db86b78c8a55d6d08
+EBUILD tifffile-2024.8.28.ebuild 912 BLAKE2B 7b97fa119ade2e06469d06a6b936633aafdf22a5a87e69965760999a1f7ce970c052bed1cd2ab09e6603f788ff152f7b59a979157bad6762203851a359f1d450 SHA512 c5808eb2dcbf785a82699f6ea0d1fe4a41811d09fdeb71a3bf83b7b0783fe570a4a01723446124ffdc3ee0d9463ec4411c5d188782f1bdab80c98bd350856697
+EBUILD tifffile-2024.8.30.ebuild 912 BLAKE2B 7b97fa119ade2e06469d06a6b936633aafdf22a5a87e69965760999a1f7ce970c052bed1cd2ab09e6603f788ff152f7b59a979157bad6762203851a359f1d450 SHA512 c5808eb2dcbf785a82699f6ea0d1fe4a41811d09fdeb71a3bf83b7b0783fe570a4a01723446124ffdc3ee0d9463ec4411c5d188782f1bdab80c98bd350856697
MISC metadata.xml 346 BLAKE2B 8cecb51fe01826a2a190c4e3020836f5706a918515a3ef5b4624fc3e9985411a8fd3c261fb7b6d8ad4f4486164487d11bdc2b071eeb5a95083db4c5323ae2dbe SHA512 81f8f6f5231d6cc9a8e7f95416a63cc52027f58fa54ce16bacfaa0ae285a48c5a3850d83d5ab50ca89be248ce386528db32811b23d61fa0d0e1e0cc737150465
diff --git a/dev-python/tifffile/tifffile-2024.6.18.ebuild b/dev-python/tifffile/tifffile-2024.8.28.ebuild
index 190a5b9ccada..a9bd677f4e53 100644
--- a/dev-python/tifffile/tifffile-2024.6.18.ebuild
+++ b/dev-python/tifffile/tifffile-2024.8.28.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
diff --git a/dev-python/tifffile/tifffile-2024.8.30.ebuild b/dev-python/tifffile/tifffile-2024.8.30.ebuild
new file mode 100644
index 000000000000..a9bd677f4e53
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2024.8.30.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.cgohlke.com/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x SKIP_LARGE=1
+ local -x SKIP_HTTP=1
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}