summaryrefslogtreecommitdiff
path: root/dev-python/textX/textX-1.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/textX/textX-1.4.ebuild')
-rw-r--r--dev-python/textX/textX-1.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/textX/textX-1.4.ebuild b/dev-python/textX/textX-1.4.ebuild
new file mode 100644
index 000000000000..e32c8487351d
--- /dev/null
+++ b/dev-python/textX/textX-1.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Meta-language for DSL implementation inspired by Xtext"
+HOMEPAGE="https://pypi.org/project/textX/ https://github.com/igordejanovic/textX"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+# pypi tarball omits tests
+RESTRICT="test"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/Arpeggio[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test -v tests/functional || die "tests failed"
+}