summaryrefslogtreecommitdiff
path: root/dev-python/testtools/testtools-1.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/testtools/testtools-1.8.0.ebuild')
-rw-r--r--dev-python/testtools/testtools-1.8.0.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/testtools/testtools-1.8.0.ebuild b/dev-python/testtools/testtools-1.8.0.ebuild
deleted file mode 100644
index 33c0a7d8f7e6..000000000000
--- a/dev-python/testtools/testtools-1.8.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Extensions to the Python standard library unit testing framework"
-HOMEPAGE="https://github.com/testing-cabal/testtools"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-CDEPEND="
- dev-python/extras[${PYTHON_USEDEP}]
- dev-python/mimeparse[${PYTHON_USEDEP}]
- >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
- >=dev-python/unittest2-1.0.0[${PYTHON_USEDEP}]
- dev-python/traceback2[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-RDEPEND="${CDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-twisted-backport.patch
- "${FILESDIR}"/${P}-twisted-backport1.patch
- "${FILESDIR}"/${P}-twisted-backport2.patch
-)
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- "${PYTHON}" -m testtools.run testtools.tests.test_suite || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( doc/_build/html/. )
-
- distutils-r1_python_install_all
-}