summaryrefslogtreecommitdiff
path: root/dev-python/testscenarios/testscenarios-0.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/testscenarios/testscenarios-0.5.0.ebuild')
-rw-r--r--dev-python/testscenarios/testscenarios-0.5.0.ebuild15
1 files changed, 5 insertions, 10 deletions
diff --git a/dev-python/testscenarios/testscenarios-0.5.0.ebuild b/dev-python/testscenarios/testscenarios-0.5.0.ebuild
index f81da08e2c7f..4c2e3e972ef6 100644
--- a/dev-python/testscenarios/testscenarios-0.5.0.ebuild
+++ b/dev-python/testscenarios/testscenarios-0.5.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6..9} pypy3 )
inherit distutils-r1
@@ -22,17 +22,12 @@ RDEPEND="
# using pytest for tests since unittest loader fails with py3.5+
DEPEND="
- ${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+ >=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
python_prepare_all() {
# Remove a faulty file from tests, missing a required attribute
rm ${PN}/tests/test_testcase.py || die
distutils-r1_python_prepare_all
}
-
-python_test() {
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}