summaryrefslogtreecommitdiff
path: root/dev-python/testfixtures/testfixtures-4.9.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/testfixtures/testfixtures-4.9.1.ebuild')
-rw-r--r--dev-python/testfixtures/testfixtures-4.9.1.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/testfixtures/testfixtures-4.9.1.ebuild b/dev-python/testfixtures/testfixtures-4.9.1.ebuild
deleted file mode 100644
index 60bd10d75f5f..000000000000
--- a/dev-python/testfixtures/testfixtures-4.9.1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
-HOMEPAGE="https://pypi.org/project/testfixtures/ https://github.com/Simplistix/testfixtures"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? (
- dev-python/manuel[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/nose-cover3[${PYTHON_USEDEP}]
- dev-python/nose_fixes[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- # Makefile comes set pointing at a wrong location
- sed \
- -e 's:../bin/sphinx-build:/usr/bin/sphinx-build:' \
- -i docs/Makefile || die
- # Prevent un-needed download during build, fix Makefile for doc build
- sed -e '/'sphinx.ext.intersphinx'/d' -i docs/conf.py || die
-
- # remove test that tests the stripped zope-component test_components.ComponentsTests
- rm -f testfixtures/tests/test_components.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- nosetests --verbosity=3 || die
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}