summaryrefslogtreecommitdiff
path: root/dev-python/tenacity/tenacity-8.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tenacity/tenacity-8.5.0.ebuild')
-rw-r--r--dev-python/tenacity/tenacity-8.5.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/tenacity/tenacity-8.5.0.ebuild b/dev-python/tenacity/tenacity-8.5.0.ebuild
new file mode 100644
index 000000000000..ec4fc6dfa03c
--- /dev/null
+++ b/dev-python/tenacity/tenacity-8.5.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="General-purpose retrying library"
+HOMEPAGE="
+ https://github.com/jd/tenacity/
+ https://pypi.org/project/tenacity/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc64 ~riscv ~sparc ~x86"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/tornado-6.4-r1[${PYTHON_USEDEP}]
+ dev-python/typeguard[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fragile to timing
+ tests/test_asyncio.py::TestContextManager::test_sleeps
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}