summaryrefslogtreecommitdiff
path: root/dev-python/tempora/tempora-5.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tempora/tempora-5.6.0.ebuild')
-rw-r--r--dev-python/tempora/tempora-5.6.0.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/tempora/tempora-5.6.0.ebuild b/dev-python/tempora/tempora-5.6.0.ebuild
deleted file mode 100644
index 7849e72a6ea3..000000000000
--- a/dev-python/tempora/tempora-5.6.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_TESTED=( pypy3 python3_{10..13} )
-PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Objects and routines pertaining to date and time"
-HOMEPAGE="
- https://github.com/jaraco/tempora/
- https://pypi.org/project/tempora/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/jaraco-functools-1.20[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- $(python_gen_cond_dep '
- dev-python/pytest-freezer[${PYTHON_USEDEP}]
- ' "${PYTHON_TESTED[@]}")
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- if ! has "${EPYTHON/./_}" "${PYTHON_TESTED[@]}"; then
- einfo "Skipping tests on ${EPYTHON}"
- return
- fi
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p freezer
-}