summaryrefslogtreecommitdiff
path: root/dev-python/tempora/tempora-1.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tempora/tempora-1.13.ebuild')
-rw-r--r--dev-python/tempora/tempora-1.13.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-python/tempora/tempora-1.13.ebuild b/dev-python/tempora/tempora-1.13.ebuild
index 55cc14bf4e43..27020aa721b6 100644
--- a/dev-python/tempora/tempora-1.13.ebuild
+++ b/dev-python/tempora/tempora-1.13.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( pypy3 python{2_7,3_{4,5,6}} )
+PYTHON_COMPAT=( pypy3 python{2_7,3_{4,5,6,7}} )
inherit distutils-r1
@@ -17,14 +17,14 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"
+# The calc-prorate binary used to be part of jaraco.utils
RDEPEND="
+ !<=dev-python/jaraco-utils-10.0.2
>=dev-python/jaraco-functools-1.20[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
-# The calc-prorate binary used to be part of jaraco.utils
DEPEND="
- !<=dev-python/jaraco-utils-10.0.2
>=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
doc? (
@@ -33,6 +33,7 @@ DEPEND="
dev-python/sphinx[${PYTHON_USEDEP}]
)
test? (
+ ${RDEPEND}
>=dev-python/pytest-2.8[${PYTHON_USEDEP}]
dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
dev-python/freezegun[${PYTHON_USEDEP}]
@@ -50,6 +51,6 @@ python_compile_all() {
python_test() {
# Override pytest options to skip flake8
- PYTHONPATH=. py.test --override-ini="addopts=--doctest-modules" \
+ PYTHONPATH=. pytest -vv --override-ini="addopts=--doctest-modules" \
|| die "tests failed with ${EPYTHON}"
}