summaryrefslogtreecommitdiff
path: root/dev-python/tempita
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tempita')
-rw-r--r--dev-python/tempita/Manifest3
-rw-r--r--dev-python/tempita/files/tempita-0.5.3-pypy-tests.patch26
-rw-r--r--dev-python/tempita/tempita-0.5.3-r2.ebuild51
3 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/tempita/Manifest b/dev-python/tempita/Manifest
index a53af13f1046..8ab3e3273d0f 100644
--- a/dev-python/tempita/Manifest
+++ b/dev-python/tempita/Manifest
@@ -1,3 +1,6 @@
+AUX tempita-0.5.3-pypy-tests.patch 933 BLAKE2B 9b49ab761c894a54f883645bbae9eba938d412aba65392fd78feffee1feadefe6f34f63f4aa7d61c5437d6697aae0dcd89434789d84055b6c089721ddb559cee SHA512 bad83c3e05d3aa8d151403ca71c527663b2268c3fee517ab5778a169b497ab491666bbb9be627369f41ba8444b6e98511953ece2744582d1abffd1ef206de312
+DIST tempita-0.5.3-bitbucket.tar.gz 22756 BLAKE2B 59d273b1dc206eea452f7e5265d59b3ef1248b2d920eae559d74f4c569852b2a127e2a906f866cb748a12663dca944d9080413410edd5c69bd93b0d9574e3026 SHA512 cebe443bf0fc7705304fe127c796801acb6cdc54e79315c2afddb79ece1d04427852c1d0924ab9dd54520b584ae09a0644a20ff2dd6ed0408ee103f5b3fb9410
DIST tempita-0.5.3.tar.gz 12707 BLAKE2B 921087bf09454506db8cab7b37c780bba5298b206113e246b710367b92364f03055afda6b826ca3008e34e4ea8821c6aabf045a735ac0887db1ba8a82e048ddb SHA512 43bafd42ab0c07bec636d637bfcd42053559d188e13bccc66527dc5f735fd9c3ec30fcf29f3e650d88315fe8f2eb2c5af280f51d2c64db099e08d8a70969a1c4
EBUILD tempita-0.5.3-r1.ebuild 613 BLAKE2B 69f6ece420faf805c3edb8b09f59f3e41ec54374b2022bcbd16b89e99c478a1b41e3357144bf95f0acf03a955927389cfd1cffe6470d7e8a2008b9a64352d73e SHA512 63892237359a101cc3f203528eea9feecde845657d5546ca4ba4d5640c64881df95928c6b775a1cd8942f52ea1e498f654f7912de3b734cf3adb2248565c6542
+EBUILD tempita-0.5.3-r2.ebuild 1364 BLAKE2B 90d1745653fd6fb93914e080c6e7eedf5084b4bd380aab249aaa263708181d3adc37966f2b5a3deb2ce9b5b291f3f4606cbf51bcb4ce81f0fdf726cd025ff80d SHA512 2dadc2d02889323f38befb2d6560736950a4dc4cb73584f9368a2345211981c5dd3f883bc37f05d3659753f51480a4fd62cf8d190c5889335c3e10d33d543b58
MISC metadata.xml 320 BLAKE2B d26cd9d2555b7d1a56ad44c86fb280a249a4f2d45c3f320cbb9a98de249e826701d49b814c209e6270d183084b8955e177fdac69af0136a7432cc5370b70fb3a SHA512 44f0ea2e06ab198180db9be4533b29c56e7cd0f3af9f522188e063cf787ad1eb1eff9fe2e09debe97be85769a09375385c1f838a7eedc2bc92835e846320f109
diff --git a/dev-python/tempita/files/tempita-0.5.3-pypy-tests.patch b/dev-python/tempita/files/tempita-0.5.3-pypy-tests.patch
new file mode 100644
index 000000000000..cdef27276be5
--- /dev/null
+++ b/dev-python/tempita/files/tempita-0.5.3-pypy-tests.patch
@@ -0,0 +1,26 @@
+diff --git a/docs/index.txt b/docs/index.txt
+index 6d943f6..afe3aa2 100644
+--- a/docs/index.txt
++++ b/docs/index.txt
+@@ -82,7 +82,7 @@ error (the name will be displayed)::
+ >>> tmpl.substitute()
+ Traceback (most recent call last):
+ ...
+- NameError: name 'name' is not defined at line 1 column 6 in file tmpl
++ NameError:... name 'name' is not defined at line 1 column 6 in file tmpl
+
+ You can also give a namespace to use by default, which
+ ``.substitute(...)`` will augment::
+diff --git a/tests/test_template.txt b/tests/test_template.txt
+index 9564a9a..d9eb55d 100644
+--- a/tests/test_template.txt
++++ b/tests/test_template.txt
+@@ -144,7 +144,7 @@ for a variable, if no value is given::
+ >>> sub('{{x}}')
+ Traceback (most recent call last):
+ ...
+- NameError: name 'x' is not defined at line 1 column 3
++ NameError:... name 'x' is not defined at line 1 column 3
+
+ And comments work::
+
diff --git a/dev-python/tempita/tempita-0.5.3-r2.ebuild b/dev-python/tempita/tempita-0.5.3-r2.ebuild
new file mode 100644
index 000000000000..738e3a004e99
--- /dev/null
+++ b/dev-python/tempita/tempita-0.5.3-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
+
+inherit distutils-r1
+
+MY_COMMIT="97392d008cc8"
+
+DESCRIPTION="A very small text templating language"
+HOMEPAGE="https://pypi.org/project/Tempita/"
+# Tests are not published on PyPI
+SRC_URI="https://bitbucket.org/ianb/${PN}/get/${MY_COMMIT}.tar.gz -> ${P}-bitbucket.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc test"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+PATCHES=( "${FILESDIR}/${P}-pypy-tests.patch" )
+
+S="${WORKDIR}/ianb-${PN}-${MY_COMMIT}"
+
+python_prepare_all() {
+ # Remove reference to a non-existent CSS file
+ # in order to make sphinx use its default theme.
+ sed -i '/^html_style =/d' docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ # We need to append to sys.path, otherwise pytest imports
+ # the module from ${S} (before it was 2to3'd)
+ pytest --import-mode=append -vv tests/test_template.txt docs/index.txt \
+ || die "Tests failed with ${EPYTHON}"
+}