summaryrefslogtreecommitdiff
path: root/dev-python/tempest
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tempest')
-rw-r--r--dev-python/tempest/Manifest4
-rw-r--r--dev-python/tempest/tempest-37.0.0.ebuild74
-rw-r--r--dev-python/tempest/tempest-38.0.0.ebuild2
3 files changed, 2 insertions, 78 deletions
diff --git a/dev-python/tempest/Manifest b/dev-python/tempest/Manifest
index 745e1e9c8487..48eca6da5cda 100644
--- a/dev-python/tempest/Manifest
+++ b/dev-python/tempest/Manifest
@@ -1,5 +1,3 @@
-DIST tempest-37.0.0.tar.gz 1146330 BLAKE2B 51acf1e0e8ce3a95d54e7b916100c32cee34f9546166fd43883f9bd5c4d4aad7d846b17c4c805392b64b9a0a02fea903c59b799f14d7e459d337eeb11c62cb6a SHA512 1de0e26c86a59c0e3f3dc494d4fdb4d3ca5ab215c1d52b34b4618e9c939ecd59b29c09bccb31bed7911517edce4cae4f9acbd2d1e28be75b0305850230528c67
DIST tempest-38.0.0.tar.gz 1148398 BLAKE2B 2905b24ebad4b5e5c83575f0d51de7eae23567dc508367a1c7a40eccbde33990152f7eebe6b7af7b9a1379b72178684b2dbf1e6d87b848b85c06ace98c8f4116 SHA512 d3a57b73e58b4898abc57e004da4a7d7e544612c498d03d4b8b2e88b36f5a160c2e74e6fea0ebd022f86dc6eb963125c45df8b932e7e012210a36e9318b548cd
-EBUILD tempest-37.0.0.ebuild 2158 BLAKE2B b7c10b1cce5f0f665bf16bf338d6ff0e1c7fdddb13a477a23b76539903fb70cacd03233a38f9bf295fae473d1df91661aa1758f39d681e0ea139a93fdf0c71af SHA512 e1e9cea83bfcc02588119d25cda7995e65b9d4f5d3af37031b112da6f1d00b77e4441b9c820f35a1ef674c5bd5e719f038c46ef439dd2a8c05c0842c908357d0
-EBUILD tempest-38.0.0.ebuild 2161 BLAKE2B 71369c13ecf600033f40a588afc14a0fd854b9be5b2647e9e54126756595a1cd4fdb596800193be5138fcb0f0673fd02232cd90a752debb4283d52bdb4c09177 SHA512 00d8febef75cbd09b421b2c3262897ce92ebcca58cd06f4b8422cef59fa3a257c0204779f73fac604804fe9cf2d4eec005e7dbc52e23e520d8a15f92c756d9d7
+EBUILD tempest-38.0.0.ebuild 2158 BLAKE2B b7c10b1cce5f0f665bf16bf338d6ff0e1c7fdddb13a477a23b76539903fb70cacd03233a38f9bf295fae473d1df91661aa1758f39d681e0ea139a93fdf0c71af SHA512 e1e9cea83bfcc02588119d25cda7995e65b9d4f5d3af37031b112da6f1d00b77e4441b9c820f35a1ef674c5bd5e719f038c46ef439dd2a8c05c0842c908357d0
MISC metadata.xml 442 BLAKE2B 30b474d10a59f53672390e029ffaf894cfe52862af42814ca09500372d4c94afc596177100b9ba69cfd12965e98809de363527d9db345c3b4cf499eaab0375f9 SHA512 d84466ecac31486c92a6c5f87089616b65a1f3cbe9447c3382021af57bec3964a80d4d4421783560528e80e70afb4f4ba604bf2a4e23ac7fcbd873ef3d789859
diff --git a/dev-python/tempest/tempest-37.0.0.ebuild b/dev-python/tempest/tempest-37.0.0.ebuild
deleted file mode 100644
index f022f1461ccb..000000000000
--- a/dev-python/tempest/tempest-37.0.0.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 2021-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 multiprocessing pypi
-
-DESCRIPTION="OpenStack Integration Testing"
-HOMEPAGE="
- https://pypi.org/project/tempest/
- https://docs.openstack.org/tempest/latest/
- https://launchpad.net/tempest/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~riscv x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
- >dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
- >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/paramiko-2.7.0[${PYTHON_USEDEP}]
- >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
- >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-4.7.0[${PYTHON_USEDEP}]
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
- >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]
- >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/defusedxml-0.7.1[${PYTHON_USEDEP}]
- >=dev-python/fasteners-0.16.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
- test? (
- >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
- dev-python/stestr[${PYTHON_USEDEP}]
- )
-"
-
-src_prepare() {
- # Small subset of tests, which fail as result of not using specific
- # testing environment.
- rm -r tempest/tests/lib/services/volume/v3/ || die
-
- # remove dep on hacking
- rm tempest/tests/test_hacking.py || die
-
- distutils-r1_src_prepare
-}
-
-python_compile() {
- distutils-r1_python_compile
- mv "${BUILD_DIR}"/install/{usr/,}etc || die
-}
-
-python_test() {
- local -x OS_LOG_CAPTURE=1 OS_STDOUT_CAPTURE=1 OS_STDERR_CAPTURE=1
- local -x OS_TEST_TIMEOUT=300
- stestr --test-path ./tempest/tests run --concurrency="$(makeopts_jobs)" ||
- die "Tests failed for ${EPYTHON}"
-}
diff --git a/dev-python/tempest/tempest-38.0.0.ebuild b/dev-python/tempest/tempest-38.0.0.ebuild
index 6821a436d77d..f022f1461ccb 100644
--- a/dev-python/tempest/tempest-38.0.0.ebuild
+++ b/dev-python/tempest/tempest-38.0.0.ebuild
@@ -17,7 +17,7 @@ HOMEPAGE="
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+KEYWORDS="amd64 ~arm arm64 ~riscv x86"
IUSE="test"
RESTRICT="!test? ( test )"