summaryrefslogtreecommitdiff
path: root/dev-python/tagpy/tagpy-2022.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tagpy/tagpy-2022.1.ebuild')
-rw-r--r--dev-python/tagpy/tagpy-2022.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/tagpy/tagpy-2022.1.ebuild b/dev-python/tagpy/tagpy-2022.1.ebuild
new file mode 100644
index 000000000000..6839fa9b82cd
--- /dev/null
+++ b/dev-python/tagpy/tagpy-2022.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Bindings for TagLib"
+HOMEPAGE="
+ https://github.com/palfrey/tagpy/
+ https://pypi.org/project/tagpy/
+"
+SRC_URI="
+ https://github.com/palfrey/tagpy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]
+ >=media-libs/taglib-1.8
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests pytest