summaryrefslogtreecommitdiff
path: root/dev-python/tablib/tablib-0.12.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tablib/tablib-0.12.1.ebuild')
-rw-r--r--dev-python/tablib/tablib-0.12.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/tablib/tablib-0.12.1.ebuild b/dev-python/tablib/tablib-0.12.1.ebuild
new file mode 100644
index 000000000000..b715f7e1fde7
--- /dev/null
+++ b/dev-python/tablib/tablib-0.12.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A format-agnostic tabular dataset library written in Python"
+HOMEPAGE="http://python-tablib.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/openpyxl[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]
+ dev-python/xlrd[${PYTHON_USEDEP}]
+ dev-python/xlwt[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ py.test -v -v || die
+}