summaryrefslogtreecommitdiff
path: root/dev-python/svgwrite/svgwrite-1.4.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/svgwrite/svgwrite-1.4.3.ebuild')
-rw-r--r--dev-python/svgwrite/svgwrite-1.4.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/svgwrite/svgwrite-1.4.3.ebuild b/dev-python/svgwrite/svgwrite-1.4.3.ebuild
new file mode 100644
index 000000000000..889031c103b9
--- /dev/null
+++ b/dev-python/svgwrite/svgwrite-1.4.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Package to write SVG files"
+HOMEPAGE="
+ https://github.com/mozman/svgwrite/
+ https://pypi.org/project/svgwrite/
+"
+SRC_URI="
+ https://github.com/mozman/svgwrite/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # fetches from the Internet
+ tests/test_style.py::TestScript::test_embed_google_web_font
+)