summaryrefslogtreecommitdiff
path: root/dev-python/sure
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sure')
-rw-r--r--dev-python/sure/sure-1.4.11.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/sure/sure-1.4.11.ebuild b/dev-python/sure/sure-1.4.11.ebuild
new file mode 100644
index 000000000000..550d962c8cb9
--- /dev/null
+++ b/dev-python/sure/sure-1.4.11.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="idiomatic assertion toolkit with human-friendly failure messages"
+HOMEPAGE="https://github.com/gabrielfalcao/sure"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )
+"
+
+python_test() {
+ nosetests -v tests || die "Tests failed under ${EPYTHON}"
+}