summaryrefslogtreecommitdiff
path: root/dev-python/sunpy/sunpy-0.7.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sunpy/sunpy-0.7.9.ebuild')
-rw-r--r--dev-python/sunpy/sunpy-0.7.9.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/sunpy/sunpy-0.7.9.ebuild b/dev-python/sunpy/sunpy-0.7.9.ebuild
deleted file mode 100644
index 9d1336d23d42..000000000000
--- a/dev-python/sunpy/sunpy-0.7.9.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1 xdg-utils
-
-DESCRIPTION="Software library for solar physics based on Python"
-HOMEPAGE="http://sunpy.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="jpeg2k test"
-
-RDEPEND="
- <dev-python/astropy-2[${PYTHON_USEDEP}]
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/suds[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
- sci-libs/scikits_image[${PYTHON_USEDEP}]
- jpeg2k? ( dev-python/glymur[${PYTHON_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- dev-python/astropy-helpers[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-mpl[${PYTHON_USEDEP}]
- )
-"
-
-python_prepare_all() {
- # use system astropy-helpers instead of bundled one
- sed -i -e '/auto_use/s/True/False/' setup.cfg || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${PYTHON}" -m pytest sunpy -k "not figure and not online" || die
-}