summaryrefslogtreecommitdiff
path: root/dev-python/sumtypes/sumtypes-0.1_alpha6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sumtypes/sumtypes-0.1_alpha6.ebuild')
-rw-r--r--dev-python/sumtypes/sumtypes-0.1_alpha6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/sumtypes/sumtypes-0.1_alpha6.ebuild b/dev-python/sumtypes/sumtypes-0.1_alpha6.ebuild
new file mode 100644
index 000000000000..0cf152ec2958
--- /dev/null
+++ b/dev-python/sumtypes/sumtypes-0.1_alpha6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${P/_alpha/a}
+DESCRIPTION="Sum Types, aka Tagged Unions, for Python"
+HOMEPAGE="
+ https://github.com/radix/sumtypes/
+ https://pypi.org/project/sumtypes/
+"
+SRC_URI="
+ https://github.com/radix/sumtypes/archive/${PV/_alpha/a}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest