summaryrefslogtreecommitdiff
path: root/dev-python/subvertpy/subvertpy-0.10.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/subvertpy/subvertpy-0.10.1.ebuild')
-rw-r--r--dev-python/subvertpy/subvertpy-0.10.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/subvertpy/subvertpy-0.10.1.ebuild b/dev-python/subvertpy/subvertpy-0.10.1.ebuild
new file mode 100644
index 000000000000..0dc9a9a7313e
--- /dev/null
+++ b/dev-python/subvertpy/subvertpy-0.10.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Alternative Python bindings for Subversion"
+HOMEPAGE="https://jelmer.uk/code/subvertpy/ https://pypi.org/project/subvertpy"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-vcs/subversion-1.4"
+DEPEND="${RDEPEND}
+ dev-libs/apr-util"
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test --args=-v
+}