summaryrefslogtreecommitdiff
path: root/dev-python/stsci-sphinxext/stsci-sphinxext-1.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/stsci-sphinxext/stsci-sphinxext-1.2.1.ebuild')
-rw-r--r--dev-python/stsci-sphinxext/stsci-sphinxext-1.2.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/stsci-sphinxext/stsci-sphinxext-1.2.1.ebuild b/dev-python/stsci-sphinxext/stsci-sphinxext-1.2.1.ebuild
new file mode 100644
index 000000000000..0c3b5c5cd13f
--- /dev/null
+++ b/dev-python/stsci-sphinxext/stsci-sphinxext-1.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+inherit distutils-r1
+
+DESCRIPTION="Tools and templates to customize Sphinx for STScI projects"
+HOMEPAGE="http://www.stsci.edu/resources/software_hardware/stsci_python"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpydoc[$(python_gen_usedep python2_7)]"
+DEPEND="${RDEPEND}
+ >=dev-python/d2to1-0.2.9[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/stsci-distutils-0.3.2[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"