summaryrefslogtreecommitdiff
path: root/dev-python/structlog/structlog-23.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/structlog/structlog-23.1.0.ebuild')
-rw-r--r--dev-python/structlog/structlog-23.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/structlog/structlog-23.1.0.ebuild b/dev-python/structlog/structlog-23.1.0.ebuild
new file mode 100644
index 000000000000..08625d392de3
--- /dev/null
+++ b/dev-python/structlog/structlog-23.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Structured Logging for Python"
+HOMEPAGE="
+ https://github.com/hynek/structlog/
+ https://pypi.org/project/structlog/
+"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest