summaryrefslogtreecommitdiff
path: root/dev-python/stripe/stripe-1.71.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/stripe/stripe-1.71.1.ebuild')
-rw-r--r--dev-python/stripe/stripe-1.71.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/stripe/stripe-1.71.1.ebuild b/dev-python/stripe/stripe-1.71.1.ebuild
new file mode 100644
index 000000000000..674033205871
--- /dev/null
+++ b/dev-python/stripe/stripe-1.71.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Stripe python bindings"
+HOMEPAGE="https://github.com/stripe/stripe-python"
+SRC_URI="mirror://pypi/s/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/requests-0.8.8"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/unittest2
+ dev-python/mock
+ dev-python/pycurl
+ )"
+
+DOCS="LONG_DESCRIPTION.rst"
+
+python_test() {
+ ${PYTHON:-python} -Wall setup.py test || die
+}