summaryrefslogtreecommitdiff
path: root/dev-python/stevedore/stevedore-1.25.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/stevedore/stevedore-1.25.0.ebuild')
-rw-r--r--dev-python/stevedore/stevedore-1.25.0.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/stevedore/stevedore-1.25.0.ebuild b/dev-python/stevedore/stevedore-1.25.0.ebuild
deleted file mode 100644
index 6b0288917a58..000000000000
--- a/dev-python/stevedore/stevedore-1.25.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Manage dynamic plugins for Python applications"
-HOMEPAGE="https://github.com/openstack/stevedore https://pypi.python.org/pypi/stevedore"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc test"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
- !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
- >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
- !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
- )
- doc? (
- >=dev-python/pillow-2.4.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
- >=dev-python/openstackdocstheme-1.11.0[${PYTHON_USEDEP}]
- >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
- !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- # Delete spurious data in requirements.txt
- sed -e '/^pbr/d' -i requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && esetup.py build_sphinx
-}
-
-python_test() {
- nosetests --verbosity=3 stevedore || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
-
- distutils-r1_python_install_all
-}