summaryrefslogtreecommitdiff
path: root/dev-python/ssl-fetch/ssl-fetch-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ssl-fetch/ssl-fetch-9999.ebuild')
-rw-r--r--dev-python/ssl-fetch/ssl-fetch-9999.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/ssl-fetch/ssl-fetch-9999.ebuild b/dev-python/ssl-fetch/ssl-fetch-9999.ebuild
new file mode 100644
index 000000000000..c7f7e4129fca
--- /dev/null
+++ b/dev-python/ssl-fetch/ssl-fetch-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+EGIT_BRANCH="master"
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="A small convenience library for fetching files securely"
+HOMEPAGE="https://github.com/dol-sen/ssl-fetch"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/dol-sen/ssl-fetch.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS=""
+
+DEPEND=""
+
+RDEPEND="${DEPEND}
+ >=dev-python/requests-1.2.1[${PYTHON_USEDEP}]
+ python_targets_python2_7? (
+ dev-python/ndg-httpsclient[python_targets_python2_7]
+ dev-python/pyasn1[python_targets_python2_7]
+ >=dev-python/pyopenssl-0.13[python_targets_python2_7]
+ )
+ "
+
+pkg_postinst() {
+ echo
+ einfo "This is experimental software."
+ einfo "The APIs it installs should be considered unstable"
+ einfo "and are subject to change."
+ echo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://github.com/dol-sen/ssl-fetch/issues"
+ einfo "I am also on IRC @ #gentoo-portage, #gentoo-keys,... of the freenode network"
+ echo
+}