summaryrefslogtreecommitdiff
path: root/dev-python/ssl-fetch/ssl-fetch-0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ssl-fetch/ssl-fetch-0.4.ebuild')
-rw-r--r--dev-python/ssl-fetch/ssl-fetch-0.4.ebuild17
1 files changed, 4 insertions, 13 deletions
diff --git a/dev-python/ssl-fetch/ssl-fetch-0.4.ebuild b/dev-python/ssl-fetch/ssl-fetch-0.4.ebuild
index 272b24e50d19..8c37254d9a30 100644
--- a/dev-python/ssl-fetch/ssl-fetch-0.4.ebuild
+++ b/dev-python/ssl-fetch/ssl-fetch-0.4.ebuild
@@ -1,31 +1,23 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
DISTUTILS_USE_SETUPTOOLS=no
-
inherit distutils-r1
-DESCRIPTION="A small convenience library for fetching files securely"
+DESCRIPTION="Small convenience library for fetching files securely"
HOMEPAGE="https://github.com/dol-sen/ssl-fetch"
SRC_URI="https://dev.gentoo.org/~dolsen/releases/ssl-fetch/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
-
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos"
-
-DEPEND=""
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos"
-RDEPEND="${DEPEND}
- >=dev-python/requests-1.2.1[${PYTHON_USEDEP}]
- "
+RDEPEND=">=dev-python/requests-1.2.1[${PYTHON_USEDEP}]"
pkg_postinst() {
- echo
elog "This is beta software."
elog "The APIs it installs should be considered unstable"
elog "and are subject to change in these early versions."
@@ -33,5 +25,4 @@ pkg_postinst() {
elog "Please file any enhancement requests, or bugs"
elog "at https://github.com/dol-sen/ssl-fetch/issues"
elog "I am also on IRC @ #gentoo-portage, #gentoo-keys,... of the Freenode network"
- echo
}