summaryrefslogtreecommitdiff
path: root/dev-python/sshtunnel/sshtunnel-0.1.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sshtunnel/sshtunnel-0.1.4-r1.ebuild')
-rw-r--r--dev-python/sshtunnel/sshtunnel-0.1.4-r1.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-python/sshtunnel/sshtunnel-0.1.4-r1.ebuild b/dev-python/sshtunnel/sshtunnel-0.1.4-r1.ebuild
deleted file mode 100644
index 64c28cd23723..000000000000
--- a/dev-python/sshtunnel/sshtunnel-0.1.4-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Pure python SSH tunnels"
-HOMEPAGE="https://pypi.python.org/pypi/sshtunnel"
-SRC_URI="mirror://pypi/s/sshtunnel/${P}.tar.gz"
-
-KEYWORDS="amd64 ~arm ~x86"
-LICENSE="MIT"
-SLOT="0"
-
-IUSE="test"
-
-RDEPEND="dev-python/paramiko[${PYTHON_USEDEP}]"
-
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- py.test --showlocals --cov sshtunnel --durations=10 -n4 tests
-}