summaryrefslogtreecommitdiff
path: root/dev-python/sqlparse/sqlparse-0.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sqlparse/sqlparse-0.5.0.ebuild')
-rw-r--r--dev-python/sqlparse/sqlparse-0.5.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/sqlparse/sqlparse-0.5.0.ebuild b/dev-python/sqlparse/sqlparse-0.5.0.ebuild
new file mode 100644
index 000000000000..f3745b336de6
--- /dev/null
+++ b/dev-python/sqlparse/sqlparse-0.5.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A non-validating SQL parser module for Python"
+HOMEPAGE="
+ https://github.com/andialbrecht/sqlparse/
+ https://pypi.org/project/sqlparse/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest