summaryrefslogtreecommitdiff
path: root/dev-python/sqlalchemy/sqlalchemy-1.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sqlalchemy/sqlalchemy-1.4.1.ebuild')
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-1.4.1.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-python/sqlalchemy/sqlalchemy-1.4.1.ebuild b/dev-python/sqlalchemy/sqlalchemy-1.4.1.ebuild
index f787e64a4497..358669239962 100644
--- a/dev-python/sqlalchemy/sqlalchemy-1.4.1.ebuild
+++ b/dev-python/sqlalchemy/sqlalchemy-1.4.1.ebuild
@@ -36,6 +36,13 @@ BDEPEND="
distutils_enable_tests pytest
+src_prepare() {
+ # remove optional/partial dep on greenlet, greenlet is not very portable
+ sed -i -e '/greenlet/d' setup.cfg || die
+
+ distutils-r1_src_prepare
+}
+
python_test() {
# Disable tests hardcoding function call counts specific to Python versions.
epytest --ignore test/aaa_profiling \