summaryrefslogtreecommitdiff
path: root/dev-python/sqlalchemy/sqlalchemy-1.3.17.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sqlalchemy/sqlalchemy-1.3.17.ebuild')
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-1.3.17.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-python/sqlalchemy/sqlalchemy-1.3.17.ebuild b/dev-python/sqlalchemy/sqlalchemy-1.3.17.ebuild
deleted file mode 100644
index 0a11e5a0e551..000000000000
--- a/dev-python/sqlalchemy/sqlalchemy-1.3.17.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-PYTHON_REQ_USE="sqlite?"
-
-inherit distutils-r1 flag-o-matic optfeature
-
-MY_PN="SQLAlchemy"
-MY_P="${MY_PN}-${PV/_beta/b}"
-
-DESCRIPTION="Python SQL toolkit and Object Relational Mapper"
-HOMEPAGE="https://www.sqlalchemy.org/ https://pypi.org/project/SQLAlchemy/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="examples +sqlite test"
-
-REQUIRED_USE="test? ( sqlite )"
-
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Disable tests hardcoding function call counts specific to Python versions.
- rm -r test/aaa_profiling || die
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- if ! python_is_python3; then
- local CFLAGS=${CFLAGS}
- append-cflags -fno-strict-aliasing
- fi
- distutils-r1_python_compile
-}
-
-python_install_all() {
- use examples && dodoc -r examples
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- optfeature "MySQL support" dev-python/mysql-python dev-python/mysql-connector-python
- optfeature "mssql support" dev-python/pymssql
- optfeature "postgresql support" dev-python/psycopg:2
-}