summaryrefslogtreecommitdiff
path: root/dev-python/sphinxemoji/sphinxemoji-0.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxemoji/sphinxemoji-0.2.0.ebuild')
-rw-r--r--dev-python/sphinxemoji/sphinxemoji-0.2.0.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/sphinxemoji/sphinxemoji-0.2.0.ebuild b/dev-python/sphinxemoji/sphinxemoji-0.2.0.ebuild
new file mode 100644
index 000000000000..196198d54ad8
--- /dev/null
+++ b/dev-python/sphinxemoji/sphinxemoji-0.2.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Extension to use emoji codes in your Sphinx documentation"
+HOMEPAGE="https://pypi.org/project/sphinxemoji/
+ https://github.com/sphinx-contrib/emojicodes"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"