summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-websupport
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxcontrib-websupport')
-rw-r--r--dev-python/sphinxcontrib-websupport/Manifest2
-rw-r--r--dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.2.7.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-websupport/Manifest b/dev-python/sphinxcontrib-websupport/Manifest
index 5891c386bcd6..a9c2933b328b 100644
--- a/dev-python/sphinxcontrib-websupport/Manifest
+++ b/dev-python/sphinxcontrib-websupport/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib_websupport-1.2.6.tar.gz 599139 BLAKE2B 661ba75c1a222993b558d2bcad0d76e99083ef8d2006526ac8d4f95228d93cb80f68638ba4e5fa245fd79e9bef13babbfcfb6c6decb1a02dd2e2623f37e88374 SHA512 d3085083132cbd9fcd289aff56a72c44f0ed8803e60996c1542da0ca1eaee7f3f38ddd2c45fc44045206091615cf69bc11bb60fb2f95ab5c6dadc2ef65251155
+DIST sphinxcontrib_websupport-1.2.7.tar.gz 599362 BLAKE2B 544e77a739e0ecd9391893f56eeec2df4d5ddc6840a30e9a92e84e35e9ed0a765d4190790a13e329621ba045ee46b5e01d4d0825b6f37e9848953f9e796ae8af SHA512 daa5ecf6fd3fb6df6a9a3b60668d42d50d93454dc3c2703a1dd43d75220b326e90c5e0ae2cca27afe62e41ae03e7144e6b4cfe70096b857af74c8981fadba9ca
EBUILD sphinxcontrib-websupport-1.2.6.ebuild 1006 BLAKE2B d3b2d1072d93085b388bf4bde9ca373ab590b8002b1a6963bac6e6983b054ad2a915faa55638871c29ff2e7ec1eae821b9bb63c97cbc5b8494bb151873648362 SHA512 e980a35a17a50066881b24b5795614556e135a77d0ff7bf25f82992049fd445305643a6bf9dc2aeadd561d3272539009ab0012a873b4c28e850c6cebe21d98e1
+EBUILD sphinxcontrib-websupport-1.2.7.ebuild 986 BLAKE2B ec942ea3fc8d0a253e17f20c937239db7041848fc1e0a30934e71601d9c052189c246787f141b7ed1b12a977670253d062cd1268f83d7d37b80194db6b2719df SHA512 0c41efc4657c0af5da08720816e61540d61875282c6ce51116b9025f978b46e9740143271452ee876744adba7ab74fe704be0e4c868dfbdecf377e455f1be848
MISC metadata.xml 614 BLAKE2B 4029475965c4514884e0ca09ca1ba257806fa222367acdc77caf7878d8564f46a6050a06e7f43a5483d9c855e746818c037dd80889fba245c3626537722281d0 SHA512 014e0efd914a7fc32fbb8bb432efd5d7e4b2efd6e189ec33da2c409281e67529de574f7708c9963723d314d45d1daefd33eeabb9f25e5af389ac0d0ed6f37d51
diff --git a/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.2.7.ebuild b/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.2.7.ebuild
new file mode 100644
index 000000000000..b1fe70d9cf12
--- /dev/null
+++ b/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.2.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx websupport extension"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-websupport/
+ https://pypi.org/project/sphinxcontrib-websupport/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+
+RDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-serializinghtml[${PYTHON_USEDEP}]
+"
+# avoid circular dependency with sphinx
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+# there are additional optional test deps on sqlalchemy and whoosh
+BDEPEND="
+ test? (
+ ${PDEPEND}
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/whoosh[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest