summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.1.0.ebuild')
-rw-r--r--dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.1.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.1.0.ebuild b/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.1.0.ebuild
new file mode 100644
index 000000000000..36f4308b2e8e
--- /dev/null
+++ b/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx websupport extension"
+HOMEPAGE="http://www.sphinx-doc.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/sqlalchemy-0.9[${PYTHON_USEDEP}]
+ >=dev-python/whoosh-2.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5[${PYTHON_USEDEP}]
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+# avoid circular dependency with sphinx
+PDEPEND="
+ >=dev-python/sphinx-1.5.3[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ ${PDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ pytest -vv tests || die "Tests fail with ${EPYTHON}"
+}