summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-plantuml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxcontrib-plantuml')
-rw-r--r--dev-python/sphinxcontrib-plantuml/Manifest3
-rw-r--r--dev-python/sphinxcontrib-plantuml/files/sphinxcontrib-plantuml-0.29-pytest-8.patch53
-rw-r--r--dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.29.ebuild50
3 files changed, 106 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-plantuml/Manifest b/dev-python/sphinxcontrib-plantuml/Manifest
index 4452aa05d320..50c46376c20c 100644
--- a/dev-python/sphinxcontrib-plantuml/Manifest
+++ b/dev-python/sphinxcontrib-plantuml/Manifest
@@ -1,3 +1,6 @@
+AUX sphinxcontrib-plantuml-0.29-pytest-8.patch 1344 BLAKE2B ff992e7101e393cd230952958d4ad4c66bff4676971030690d66317778de72a2df4813bd9260e8466df924b20b9cb8532691a98b1a91aebc8d5f1bc257fbbcd7 SHA512 d12d62fdb4800e7a9538ea2a7235bca8e0d94a1c0144d633a7bea940a54190581c04116a9c2615b21c19b5318dd0a7db21f8f9c05bc0fc3532ad5c8e4397f8b6
DIST sphinxcontrib-plantuml-0.28.gh.tar.gz 19322 BLAKE2B b76166130ddcebc9312ea40d20dd0710403566a989dfdc40b906a724b32d8e3b53d50a4db1871e771eafb46f9cfea463f58348910c4bdeed0f25996269be8dea SHA512 52553e8ee5a9dbb3644f28a26f6be48a910e2013673169a8a9f0776406f6453b2443967af1837056010b0621d681e7fd00ab590858b07665bb74699c81aa81e2
+DIST sphinxcontrib-plantuml-0.29.gh.tar.gz 19376 BLAKE2B c410be6af6364e347dd1b8e782e55d9cea1c799dc3e2d5055c893b37e437c5e300cafc79e70947447979fe4b11d97fab7cddd6e0894654e274cd05cb5d4abba3 SHA512 9bcec86db5956dd9cbad097ad52b5dc915598c3324662491229268689c3c57c5ce680b38e38ff3360a109f3fd50753c92252ecaf928b124f9a515f52d1da93b4
EBUILD sphinxcontrib-plantuml-0.28.ebuild 1017 BLAKE2B 5f9f62b2132e00d0a3f57cc2bcc3fddc81d806cf525ed5488334205f98f953778938c47f0c88205d8dcf02b43262c838f2cb14b9f28c2c8b41c85f7baa0d7a47 SHA512 47d30c5f614090e4e2569ae6cd1057160f8b7ecc2c14ce306809aea5bba15e4cf440c7cb54d994a324984237fe705d7d8903620ef0614a8a29a5e2aa29b5740e
+EBUILD sphinxcontrib-plantuml-0.29.ebuild 1204 BLAKE2B fc2d0f87f7cf9ce4f767945bbef94ad99b63565f464b5c8e2dc50b5e7b764cf6d9161d4e80f87ffd8d0b137b7dbce5ba8fe524578f9950b4c0a925ac3b6d8e76 SHA512 3f0c8bcbd6a721457243dccb09b0b794493ac720a7c0f7ca1b246f958399d24b1d6903bd5a2516b0686647b533becc7269d3b760b9b9c790cec782a05a8ad3e5
MISC metadata.xml 419 BLAKE2B 05ba888453b1a19e83a8d21a5b0cc2a5a24482434b44c0f3bd4c75c99004523f6397a7a32811a336c15449ea86f1736e5a940d240d19f3956a176fce3881378d SHA512 6d8c4c646e7d84771a7ac7889650c06a0efcaa708d5e009df323f4d8ee591c75d864811ba10dde72b84f40359092302225a93d8de374da8d52033163356d6f46
diff --git a/dev-python/sphinxcontrib-plantuml/files/sphinxcontrib-plantuml-0.29-pytest-8.patch b/dev-python/sphinxcontrib-plantuml/files/sphinxcontrib-plantuml-0.29-pytest-8.patch
new file mode 100644
index 000000000000..2f10e1fae51d
--- /dev/null
+++ b/dev-python/sphinxcontrib-plantuml/files/sphinxcontrib-plantuml-0.29-pytest-8.patch
@@ -0,0 +1,53 @@
+From 74e31ad4dd8f4fefd5b9e430e4d9caea3002fd97 Mon Sep 17 00:00:00 2001
+From: Yuya Nishihara <yuya@tcha.org>
+Date: Sun, 10 Mar 2024 19:30:21 +0900
+Subject: [PATCH] tests: rename setup/teardown functions for pytest 8.1.1
+ compatibility
+
+I don't know if that's intended, but nose-style setup() is no longer called.
+---
+ tests/test_functional.py | 4 ++--
+ tests/test_svgstyle.py | 4 ++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/tests/test_functional.py b/tests/test_functional.py
+index 697b01d..8ef6a3d 100644
+--- a/tests/test_functional.py
++++ b/tests/test_functional.py
+@@ -12,7 +12,7 @@
+ _fakecmd = os.path.join(os.path.dirname(__file__), 'fakecmd.py')
+
+
+-def setup():
++def setup_module():
+ global _tempdir, _srcdir, _outdir
+ _tempdir = tempfile.mkdtemp()
+ _srcdir = os.path.join(_tempdir, 'src')
+@@ -20,7 +20,7 @@ def setup():
+ os.mkdir(_srcdir)
+
+
+-def teardown():
++def teardown_module():
+ shutil.rmtree(_tempdir)
+
+
+diff --git a/tests/test_svgstyle.py b/tests/test_svgstyle.py
+index c62e1ed..a25901f 100644
+--- a/tests/test_svgstyle.py
++++ b/tests/test_svgstyle.py
+@@ -5,12 +5,12 @@
+ from sphinxcontrib import plantuml
+
+
+-def setup():
++def setup_module():
+ global _tempdir
+ _tempdir = tempfile.mkdtemp()
+
+
+-def teardown():
++def teardown_module():
+ shutil.rmtree(_tempdir)
+
+
diff --git a/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.29.ebuild b/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.29.ebuild
new file mode 100644
index 000000000000..c3b27de3b09c
--- /dev/null
+++ b/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.29.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extensions for PlantUML"
+HOMEPAGE="
+ https://github.com/sphinx-contrib/plantuml/
+ https://pypi.org/project/sphinxcontrib-plantuml/
+"
+SRC_URI="
+ https://github.com/sphinx-contrib/plantuml/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${P#sphinxcontrib-}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+BDEPEND="
+ test? (
+ app-text/texlive
+ dev-python/sphinxcontrib-applehelp[${PYTHON_USEDEP}]
+ dev-tex/latexmk
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latexextra
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/sphinx-contrib/plantuml/commit/74e31ad4dd8f4fefd5b9e430e4d9caea3002fd97
+ "${FILESDIR}/${P}-pytest-8.patch"
+)
+
+python_test() {
+ # Fix for sphinx.errors.ExtensionError: Could not import extension sphinxcontrib.applehelp
+ # See https://projects.gentoo.org/python/guide/test.html#importerrors-for-c-extensions, thanks to mgorny.
+ rm -rf sphinxcontrib || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}