summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-htmlhelp
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxcontrib-htmlhelp')
-rw-r--r--dev-python/sphinxcontrib-htmlhelp/Manifest2
-rw-r--r--dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.0.1.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-htmlhelp/Manifest b/dev-python/sphinxcontrib-htmlhelp/Manifest
index edae5b0473ae..6ffac97af098 100644
--- a/dev-python/sphinxcontrib-htmlhelp/Manifest
+++ b/dev-python/sphinxcontrib-htmlhelp/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib-htmlhelp-2.0.0.tar.gz 28144 BLAKE2B 09b0d9bcec57140278c4476fa0bbc40d359fc167d8ea891a1585fbdeafe6eb0b52442dbbc8d1d5b6edb3953b04fc29a71f6f74e58a281ebb0d79e5a30cb02749 SHA512 6ed673966615f3e818e00de4b7e59c27f0a0d7b494294f804540777c580480870c36002c08d8ad626b7b41a676fe40edc0b0b5ffc6ad8080f38f59c24e157636
+DIST sphinxcontrib-htmlhelp-2.0.1.tar.gz 27967 BLAKE2B 922921a52c421bde9787df6fd5107a515bb0af4f4a6a6c8b84f474b9d7b0ce9251437b8780b3464190e494555bbe6d72604e155bce98794c36c03ddbcc5c4cc7 SHA512 7957ad688d7f9d44c0413fd747147e8e261136d48ed159fef4e668dcab76c54103028102a9ed893bfadbd175b88543e0d1414b8e01a716810d44b92edfbd79e5
EBUILD sphinxcontrib-htmlhelp-2.0.0-r1.ebuild 1014 BLAKE2B c8e115fe34583a2cfed0b791cbdc5d99ed419dbf8b771c49d889a2441be06ff7696e5f8e9fcef2459f60ddaf054b478b714ab8aea8320b7bd51b1bb3802ef5e9 SHA512 73fcaa51518259bdd402b28e8733f5b26a3b3c74570fc5e1eeaddbe0f5f42ecae75304e5292a854d8211256695c388fa9b24d8467ddf5496be3627e1ce6755e8
+EBUILD sphinxcontrib-htmlhelp-2.0.1.ebuild 1022 BLAKE2B fcc379a0181f56153f92b0f855a8ba9f82b084ae8a7a03bc9dcfff551cc67131f420c8ca24f32537f8dca3ca84c3afaf3e94cbe77b78c2b163659e74fc9188c1 SHA512 255bc4d854d42c412f01819c8e033faa9f00b1866c233d8600d5f2ad82b766cdedffb03aa93f1247442da14b4811cde91e2fa7755ba36240bd471c6f3d4a9e4a
MISC metadata.xml 423 BLAKE2B 49685b4a452f9f05a9f385c7c1913c282bd0714e1c92e42347960bdfa29ae01ed4eba7f43e3d1b7241d6bca4ddf4f8d3e0a1d0820a8af5edb7caca934908ecdf SHA512 8f497fb7ea0724be086c8a564481cf4d46ecf048791f76ed5494a7b0c0f46bf5eaf46875f0695b9add2914430c78427a5a77113a5f379052922217b415bfdb50
diff --git a/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.0.1.ebuild b/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.0.1.ebuild
new file mode 100644
index 000000000000..68ce8456f5f4
--- /dev/null
+++ b/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension which outputs HTML help book"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-htmlhelp/
+ https://pypi.org/project/sphinxcontrib-htmlhelp/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${PDEPEND}
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ distutils_write_namespace sphinxcontrib
+ cd "${T}" || die
+ epytest "${S}"/tests
+}