summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-htmlhelp
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxcontrib-htmlhelp')
-rw-r--r--dev-python/sphinxcontrib-htmlhelp/Manifest2
-rw-r--r--dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.0.5.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-htmlhelp/Manifest b/dev-python/sphinxcontrib-htmlhelp/Manifest
index 248d89d27666..6e3fad018873 100644
--- a/dev-python/sphinxcontrib-htmlhelp/Manifest
+++ b/dev-python/sphinxcontrib-htmlhelp/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib_htmlhelp-2.0.4.tar.gz 21799 BLAKE2B ef5f5c26696cadc37feefda8b5343562efd45ab7685d472d820f4e391a1699993f26634269087c24971b176ef7b05e0191f90dc6b07093ca25a424bbf7a2a69d SHA512 5f1c4619b986060fb6213e23b5339b7b5d57abdb8f6034473116c9ea7c3d04cf0985115141c5325cb93bac330eb6109d2e81327f53fda78838c9ed5435469b29
+DIST sphinxcontrib_htmlhelp-2.0.5.tar.gz 21925 BLAKE2B ba023e53c14b5427b09a9608cfc45ccdf932d4c27cce40932088fadb127ebfe50d7b2639513589469facf108fdc748e0f07195766e6e4bc67d26c50d00a2bf75 SHA512 537ef6a1a32863728a6324fcd50f9374e4f488ed7ed112f9f0ceb9e4488637f502280dda21835e8d63c6b6297d2a3db3032c3f307dce5948b516f293d07b9711
EBUILD sphinxcontrib-htmlhelp-2.0.4.ebuild 759 BLAKE2B ec109eca36ae29296b4759ae121851e71696e0413db6eb6f7c1eb5c7b895172bbd18e9eca08486cb52cf369d11ad65e440e5722025b5c99bf455cad798a95a58 SHA512 5cf1fbcec239ba968a36328c3dd310704046471c864d9a17210de63880fdcbbdb889ef40499b99fd591a3c5e01b85a8e81d982c9efcd24cccc6e78877c1fda9e
+EBUILD sphinxcontrib-htmlhelp-2.0.5.ebuild 767 BLAKE2B 053cda5c5b9d8a182dea9e3a1dc05e9aad54a062ec00f65063ffac3e630419ca94967831219bbb24bbe2369fa8107488d4fd8389222d2bbfbea2743eb4d7f7e0 SHA512 6cd8b6a27a1d3778e839f599a10e3f1368fca9d596450d5fefa141443e985306d69357848f173b4fa715580f2f1045456d4b8d561f6571c784faac22e149e73b
MISC metadata.xml 423 BLAKE2B 49685b4a452f9f05a9f385c7c1913c282bd0714e1c92e42347960bdfa29ae01ed4eba7f43e3d1b7241d6bca4ddf4f8d3e0a1d0820a8af5edb7caca934908ecdf SHA512 8f497fb7ea0724be086c8a564481cf4d46ecf048791f76ed5494a7b0c0f46bf5eaf46875f0695b9add2914430c78427a5a77113a5f379052922217b415bfdb50
diff --git a/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.0.5.ebuild b/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.0.5.ebuild
new file mode 100644
index 000000000000..3069fe73f963
--- /dev/null
+++ b/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.0.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which outputs HTML help book"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-htmlhelp/
+ https://pypi.org/project/sphinxcontrib-htmlhelp/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${PDEPEND}
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest